SRXForum.net Bookmark and Share
September 02, 2014, 04:32:14 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Forum Tip: Click the little blue 'new' icon next to any topic to jump right to the first unread message.
   
   Home   Help Search Gallery Login Register  
Registered users see fewer ads.
Pages: [1] 2 3 ... 41   Go Down
 
Subject Started by Replies Views Last post
0 Members and 25 Guests are viewing this board.
power steering struggling at idle suprcharg 12 426 Last post Yesterday at 11:43:22 PM
by Chas
Not sure what this is!! « 1 2  All » momandrich94 26 1314 Last post Yesterday at 11:32:45 PM
by Chas
2013 2.4 ok? « 1 2  All » rjc1629 30 2255 Last post Yesterday at 08:37:40 PM
by buickanddeere
2010 2.4L Coolant Temp Sensor Location bigmitch 1 160 Last post Yesterday at 06:10:26 PM
by Toolaa2000
Transmission Slams Into Gear rudes 0 130 Last post August 30, 2014, 11:35:12 AM
by rudes
2010 Equinox intermittent starting issue after sits in the sun all day. mapesii 3 206 Last post August 30, 2014, 10:19:05 AM
by momandrich94
Serpentine Belt Squeak on Start up. bjall4jc 3 258 Last post August 30, 2014, 05:01:27 AM
by Davek
TIMING CHAIN!!! 2.4 Liter 4 banger horror story... « 1 2 3 4 5 » eeks and knocks 91 46504 Last post August 28, 2014, 06:31:32 AM
by Ralphalph
2005 Equinox starting problem jshack 6 321 Last post August 27, 2014, 11:50:31 AM
by jshack
eco, stabillitrack and usb rid 2 223 Last post August 27, 2014, 11:32:02 AM
by Chas
Injection event timing and octane ? buickanddeere 4 452 Last post August 26, 2014, 04:02:54 PM
by buickanddeere
VERY unhappy Equinox owner!!! « 1 2  All » gizmoluvsme 27 1439 Last post August 23, 2014, 11:47:46 AM
by poppabusa
Transmission lunging and bucking mwwh2o 6 708 Last post August 23, 2014, 04:15:42 AM
by Chas
Very hard SLAM shift 1-2 bhamer2 16 1430 Last post August 22, 2014, 08:21:19 PM
by Default User
2012 Timing Chain Ralphalph 2 319 Last post August 22, 2014, 06:15:04 AM
by Ralphalph
More Engine Problems charlie1234 7 512 Last post August 21, 2014, 12:11:33 PM
by Ralphalph
Ticking noise when accelerating. Tattooed Hunter 2 273 Last post August 21, 2014, 09:28:03 AM
by Tattooed Hunter
Most miles on an I4 engine ? « 1 2  All » lucky55616 33 2325 Last post August 21, 2014, 09:12:48 AM
by codemanrose
Do you use any oil additives like oil stabilizers? lansuminc 18 1068 Last post August 20, 2014, 08:45:00 PM
by dwendt44
P0014 Exhaust Camshaft Performance CEL Code WVDave 8 702 Last post August 19, 2014, 11:12:30 AM
by Ralphalph
Pages: [1] 2 3 ... 41   Go Up
 

Topic you have posted in
Normal Topic
Hot Topic (More than 15 replies)
Very Hot Topic (More than 25 replies)
Locked Topic
Sticky Topic
Poll
:  
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines | Sitemap
©2014 SRXForum.net All Rights Reserved.
All trademarks referenced herein are property of their respective owners.
Valid XHTML 1.0! Valid CSS!